For something that's supposed to be THE defining characteristic of REST, it could have done with better naming.
I would have been happy with the term HatEoAS if it had stood for "Hypermedia as the Envelope of Application State" rather than "Hypermedia as the Engine of Application State".
An Engine actively drives things. E.g., A process engine is well named, because it drives a process.
A constraint doesn't drive anything. It constrains. It provides an envelope around the range of possibilities.
And so they really should have called this an envelope rather than an engine of application state.
There, I've said it. Because the expansion of HatEoAS has been driving me up the wall.
Fortunately, it's being referred to as "Hypermedia Constraint" now, which is both more elegant and more accurate.